Add a existent server

Maybe something related in the way the page connect in the servers.

seems to me, when a want to do something, the page needs to connect again to the servers.

something like a session timeout.

sorry, I don`t understand well about programing.

Julio

Could you send me the console output when u send some rcon commands via website.

Hi Neho,

I solved that issue... I was setting the external IP of my vps in the config.json.

I reinstalled every from de begining , and a tryed the internal IP and it`s worked.

Sorry, but I have another doubt.

to use the screen upload, I insert this lines to my config file, like the server configuration page say to do:

loadplugin nehoscreenshotuploader
set nehoscreenshot_identkey "cod4server1"
set nehoscreenshot_url "http://wwww.kgameclan.com/cod4x_plugins/screenshots/cod4server1"

I dont know if I need to do something more, becouse I`m receiving a message when starting the server.

Error: Init failure. Cvar nehoscreenshot_identkey or nehoscreenshot_url is not set
Error in plugin's OnInit function!
Plugin load failed.

Iam using this version:


CoD4X Auto Update
Current version: 1.8
Current subversion: 17.7
Current build: 922

I thinking to post this question on cod4x forum, but I don`t know if I need something more in the page.

Thanks a lot.

Julio

Delete all plugin inside this folder

main-server-files/plugins

You should have only an empty plugins folder. This plugins what u have there are outdated and they will not work, just delete them and you will be fine

I removed the plugins from the folder, but the error message still there.

Follow the output from npm, the timeouts are when the page not responde the commands:

root@codserver02:/var/www/html# npm start
> CoD4x-WebaAdmin@0.0.4 start /var/www/html
> node ./bin/www
(node:2131) DeprecationWarning: collection.count is deprecated, and will be removed in a future version. Use collection.co
untDocuments or collection.estimatedDocumentCount instead
(node:2131) DeprecationWarning: collection.update is deprecated. Use updateOne, updateMany, or bulkWrite instead.
GET / 200 1391.251 ms - 7286
(node:2131) DeprecationWarning: collection.findAndModify is deprecated. Use findOneAndUpdate, findOneAndReplace or findOne
AndDelete instead.
GET / 304 368.478 ms - -
Done going through Servers!
There was an error - Plugin refresh players list: timeout
GET /kgame-hc-raiz 200 753.742 ms - 17711
GET /kgame-hc-raiz 200 569.791 ms - 17711
GET /kgame-hc-raiz 200 395.861 ms - 17711
GET /admin/home 200 518.877 ms - 17720
GET /admin/stop-local-server/5bb30fd46bf48132678060dc 302 90.148 ms - 116
GET /admin/home 200 400.582 ms - 17862
No screen session found.
GET /admin/start-local-server/5bb30fd46bf48132678060dc 302 10.054 ms - 116
GET /admin/home 200 345.323 ms - 17855
(node:2131) DeprecationWarning: collection.remove is deprecated. Use deleteOne, deleteMany, or bulkWrite instead.
timeout
GET / 200 419.013 ms - 7284
GET /kgame-hc-raiz 200 701.260 ms - 17711
GET /kgame-hc-raiz 200 372.343 ms - 19280
POST /rconcmd/5bb30fd46bf48132678060dc/getss - - ms - -
GET / 200 365.484 ms - 7280
GET /admin/home 200 466.643 ms - 17720
GET /admin/servers/rconconsole/5bb30fd46bf48132678060dc 200 355.561 ms - 12484
Done going through Servers!
Done going through Servers!
POST /admin/servers/rconconsole/send/5bb30fd46bf48132678060dc - - ms - -
POST /admin/servers/rconconsole/send/5bb30fd46bf48132678060dc 302 149.878 ms - 146
GET /admin/servers/rconconsole/5bb30fd46bf48132678060dc 200 426.715 ms - 13016
GET / 200 356.204 ms - 7281
GET /kgame-hc-raiz 200 598.040 ms - 19280
POST /rconcmd/5bb30fd46bf48132678060dc/getss 302 167.044 ms - 122
GET /kgame-hc-raiz 200 372.609 ms - 19449
timeout
POST /rconcmd/5bb30fd46bf48132678060dc/getss 302 111.186 ms - 122
GET /kgame-hc-raiz 200 543.524 ms - 17873
last edited by NeHo

You have mixed up things, the plugins what u have to remove are inside main-server-files folder, and that is a part of Call of Duty server, it has nothing to do with the website.

if u have the plugins symlinked inside your cod4-port server remove that part to, maybe you have created the server before you have removed the plugins as I told you, it means that you have some symlinked plugins what you don't need.

Also screenshots work only if there are at least 2 (active) players on the server, if you are alone the screenshot will be not fired

Hi Neho,

I did what you said.... Appear that worked, but the errors message changed:

Error: Init failure. Server returned code 404 and message command=HELO&identkey=cod4server1&serverport=28960&gamename=Call%20of%20Duty%204%20-%20Modern%20Warfare%20X18&gamedir=cod4&rcon=123

last edited by Amievil

rcon must be at least 8 characters long....

It have, I changed to not show it in this message...

Make sure that you have deleted all the old plugins in this 2 directories

cod4-28960/plugins

and

main-server-files/plugins

Download the latest CoD4x release from here and upload it to main-server-files folder
https://cod4x.me/

chmode the "cod4x18_dedrun" to 755

After this steps if you start the server it should work