Add a existent server

Have you set the IP inside config.json file, since that part should be the problem, It can not read from there your server ip so it don't know what country your server is from and it drops the error

"host" : "your-server-ip",

This is the file what you have to change

After you change the file don't forget to restart the application (the npm start part)

If you use PM2 to run the application u can restart it with command

sudo PM2 reload all
last edited by NeHo

Thank you for you help...

I`was setting in localhost in "your-server-ip", that was the issue.

I've been using it since Saturday, and its` amazing.

But I have another doubt.

sometimes when I have the page open and I need to change maps or ban users, the page hang for a time, and I receive a timeout error page.

I need to refresh and try some times to the page works.

Do You want that I create another forum topic for this question?

Thank you

This error can be caused when the is not working properly. To see if the works check if you have the server list. It is located in the top right corner (you have to be logged in to see it), a small link with monitor on it if u click on it you will see a text like "Join Servers with 1 click here" and under it you should have your servers listed, small map images with links, if you can see the servers listed there then the error is not caused by

This is how it looks on my page, on the right side


Timeout happens when for some reason you could not connect to the server and execute the wished command

Also make sure that u don't set the rcon password in your game servers server.cfg file, it is set in the command line for security reasons, if u navigate to the Admin page go to server edit, there you will see the start commandline, it is called "Server start line" (this part +set rcon_password xxxxxxxxx)

I`ve this option in the site, and I able to connect in the game using the link:


I don`t have the rcon password in the server.cfg


last edited by Amievil

Maybe something related in the way the page connect in the servers.

seems to me, when a want to do something, the page needs to connect again to the servers.

something like a session timeout.

sorry, I don`t understand well about programing.


Could you send me the console output when u send some rcon commands via website.

Hi Neho,

I solved that issue... I was setting the external IP of my vps in the config.json.

I reinstalled every from de begining , and a tryed the internal IP and it`s worked.

Sorry, but I have another doubt.

to use the screen upload, I insert this lines to my config file, like the server configuration page say to do:

loadplugin nehoscreenshotuploader
set nehoscreenshot_identkey "cod4server1"
set nehoscreenshot_url ""

I dont know if I need to do something more, becouse I`m receiving a message when starting the server.

Error: Init failure. Cvar nehoscreenshot_identkey or nehoscreenshot_url is not set
Error in plugin's OnInit function!
Plugin load failed.

Iam using this version:

CoD4X Auto Update
Current version: 1.8
Current subversion: 17.7
Current build: 922

I thinking to post this question on cod4x forum, but I don`t know if I need something more in the page.

Thanks a lot.


Delete all plugin inside this folder


You should have only an empty plugins folder. This plugins what u have there are outdated and they will not work, just delete them and you will be fine

I removed the plugins from the folder, but the error message still there.

Follow the output from npm, the timeouts are when the page not responde the commands:

root@codserver02:/var/www/html# npm start
> CoD4x-WebaAdmin@0.0.4 start /var/www/html
> node ./bin/www
(node:2131) DeprecationWarning: collection.count is deprecated, and will be removed in a future version. Use
untDocuments or collection.estimatedDocumentCount instead
(node:2131) DeprecationWarning: collection.update is deprecated. Use updateOne, updateMany, or bulkWrite instead.
GET / 200 1391.251 ms - 7286
(node:2131) DeprecationWarning: collection.findAndModify is deprecated. Use findOneAndUpdate, findOneAndReplace or findOne
AndDelete instead.
GET / 304 368.478 ms - -
Done going through Servers!
There was an error - Plugin refresh players list: timeout
GET /kgame-hc-raiz 200 753.742 ms - 17711
GET /kgame-hc-raiz 200 569.791 ms - 17711
GET /kgame-hc-raiz 200 395.861 ms - 17711
GET /admin/home 200 518.877 ms - 17720
GET /admin/stop-local-server/5bb30fd46bf48132678060dc 302 90.148 ms - 116
GET /admin/home 200 400.582 ms - 17862
No screen session found.
GET /admin/start-local-server/5bb30fd46bf48132678060dc 302 10.054 ms - 116
GET /admin/home 200 345.323 ms - 17855
(node:2131) DeprecationWarning: collection.remove is deprecated. Use deleteOne, deleteMany, or bulkWrite instead.
GET / 200 419.013 ms - 7284
GET /kgame-hc-raiz 200 701.260 ms - 17711
GET /kgame-hc-raiz 200 372.343 ms - 19280
POST /rconcmd/5bb30fd46bf48132678060dc/getss - - ms - -
GET / 200 365.484 ms - 7280
GET /admin/home 200 466.643 ms - 17720
GET /admin/servers/rconconsole/5bb30fd46bf48132678060dc 200 355.561 ms - 12484
Done going through Servers!
Done going through Servers!
POST /admin/servers/rconconsole/send/5bb30fd46bf48132678060dc - - ms - -
POST /admin/servers/rconconsole/send/5bb30fd46bf48132678060dc 302 149.878 ms - 146
GET /admin/servers/rconconsole/5bb30fd46bf48132678060dc 200 426.715 ms - 13016
GET / 200 356.204 ms - 7281
GET /kgame-hc-raiz 200 598.040 ms - 19280
POST /rconcmd/5bb30fd46bf48132678060dc/getss 302 167.044 ms - 122
GET /kgame-hc-raiz 200 372.609 ms - 19449
POST /rconcmd/5bb30fd46bf48132678060dc/getss 302 111.186 ms - 122
GET /kgame-hc-raiz 200 543.524 ms - 17873
last edited by NeHo

You have mixed up things, the plugins what u have to remove are inside main-server-files folder, and that is a part of Call of Duty server, it has nothing to do with the website.

if u have the plugins symlinked inside your cod4-port server remove that part to, maybe you have created the server before you have removed the plugins as I told you, it means that you have some symlinked plugins what you don't need.

Also screenshots work only if there are at least 2 (active) players on the server, if you are alone the screenshot will be not fired

Hi Neho,

I did what you said.... Appear that worked, but the errors message changed:

Error: Init failure. Server returned code 404 and message command=HELO&identkey=cod4server1&serverport=28960&gamename=Call%20of%20Duty%204%20-%20Modern%20Warfare%20X18&gamedir=cod4&rcon=123

last edited by Amievil

rcon must be at least 8 characters long....

It have, I changed to not show it in this message...

Make sure that you have deleted all the old plugins in this 2 directories




Download the latest CoD4x release from here and upload it to main-server-files folder

chmode the "cod4x18_dedrun" to 755

After this steps if you start the server it should work