Player Stats Not Updating?

Does it take time for top 25 player stats to be updated? It was working before and on one of the servers the other day. Something I am missing?

We played all night tonight and only a few stats appeared. Some with 0 0 0

Thx in advance.

Did not check if they update, you can see if it updates based on you kills sum. Stats update after map change, if the server has only 1 map then the stats wont work, need to fix that in future for servers with only 1 map

last edited by NeHo

@NeHo said in Player Stats Not Updating?:

Did not check if they update, you can see if it updates based on you kills sum. Stats update after map change, if the server has only 1 map then the stats wont work, need to fix that in future for servers with only 1 map

They were not updating and all servers have multiple maps. I have restarted all and reset stats and will watch again tomorrow and see how it goes. Will report back.

thnx, I checked the code, it should work

100% not updating. Checked scores after maps rotated, waited and waited.

A day ago you sent me a PM that the stats is working, now it is not working 🙂 Will check my application to see if it works there 🙂

It was working , but it takes some stats and it seems not all. When I PM you I did not see that at that time. It is not consistent at the moment from what I can see.

Whilst you are in that actual map and see the player list 'live' you can seethe KD Ratio. When the map rotated those kills are not in the TOP 25.

Does a player have to play so many maps before anything gets registered? We are trying to reset player stats again and see what happens.

I don't know what your issue is, I just followed my top 1 player, after the map changed his stats also changed. So this issue doesn't exist on my application.

Stats update after the map name changes

I am waiting to see. If you manually rotate the map it seems stats are not updated. If you let map run its course then they are. That's what we are testing now.

Its registering the K/D/Assist's

2020-05-12 22_27_06-=FMJ=Snipers_TDM_ - =FMJ=CoD4X WebAdmin.png

After the map rotated only 1 player shows in the top 25 even though there were kills from all three players?

Going to try another server now and see again.

Players that have just joined and stayed without any kills still appear in top 25

2020-05-12 22_35_31-=FMJ=WorldWar2_1944_ - =FMJ=CoD4X WebAdmin.png

Ok so it registers some players and not others. If it takes time I don't know but its updating on the 'live' part and the top 25 is all over the place, registers some but most definitely not all! 🙂

You say this. Why would this only be different for me if this is my issue?

No need to post after every round 🙂 Stats will be changed 1 day when I get to that part. Right now I am working on something else, so even if this is not working since it will be changed in future I will not waste time on it.

Keep also in mind that I can not work on this 0-24, I have to pay my bills and would also like to have some private time.

Now we know that something is wrong with this part I will look at it when I get time, it will be fixed.

Thnx for letting me know

@NeHo said in Player Stats Not Updating?:

No need to post after every round 🙂

I'm not posting every round 🙂 The first is showing the K/D being recorded, the second shows that it is not recorded after map rotation 🙂

We ALL appreciate your hard work NeHo and yes this part is not so important.

Thx 🤝

Would like to add that there is no player chat history also. 😕

works on my application since then, not sure what you are doing

I would expect nothing else that it all worked for you 😛 I have done nothing other than install it as per instruction!! Why would i do anything else? 😕

My update to 4.0.1 went smooth with no errors. Player stats are not updating properly as said above and there is NO chat history at all.

Maybe it is permissions/write thing?

It can not be permission because julia sends the message to web and there we store it in db. Since you have reinstalled it make sure you use the new julia plugin, I shared it in v4 release, or compile it

Ok thanks NeHo I will grab that and update. Report back.