WebAdmin Install: A lot further than before but not quite there!


  • Last time was a disaster, so much so that I had to reinstall whole Linux OS again!

    Further this time but get a error's once I npm start at the end.

    2020-04-26 17_56_23-192.168.1.4 - PuTTY.png

    Would love to get some help please. Smiley.

  • Administrators

    @FMJ-Smiley

    sudo ln -s "$(which nodejs)" /usr/bin/node
    

    Or if you would not like it that way replace this line

    https://github.com/byNeHo/CoD4x-WebAdmin/blob/master/package.json#L6

    to this

    "start": "nodejs ./bin/www",
    

  • Thanks for the reply.

    Being cautious as I have spent days on this. I chose your second method and changed line 6 but have error also. ! If i use the ln -s method is that ok? Will it effect anything else?
    2020-04-26 23_13_03-WebAdmin Install_ A lot further than before but not quite there! _ Cirkus Server.png

  • Administrators

    No it will not affect anything, it will create a symlink to use node instead of nodejs


  • Ok, I used both methods and same error as above. ☹

  • Administrators

    @FMJ-Smiley please send me the output for this command

    node -v
    

  • Thank you very much for the help. Managed to now get the application running.

    Now having a problem viewing the application in the browser. This is obviously something local. Port 3000 is open but still cannot view.

    Will keep trying and hopefully post again when a solution is found! Closer each time but hoped it would not have been this difficult 🙂 No chance on my own that's for sure 🙂


  • I must be the only one with this error i guess. With all the different hardware/software/OS versions none of this can be straight forward 🙂 If it was lucky you 🙂 Should port 3000 be on tcp6 ? node is using port 3000 but i do not see the application. Should be on tcp maybe?

    2020-04-27 10_51_26-192.168.1.4 - PuTTY.png

    Also how do I get this? 3 lines? Ok I stopped 2 but should pm2 status just give me the 1 line for cod4xwebadmin?

    2020-04-27 10_56_23-192.168.1.4 - PuTTY.png

  • Administrators

    @FMJ-Smiley To delete from list (1 is the ID)

    pm2 delete 1
    

    To delete all type

    pm2 delete all
    

    The tutorial what I sent you in PM is here
    https://forum.cirkus-serveri.com/topic/66/keep-application-alive-forever-with-pm2

    More Info and configuration can be found here
    https://pm2.keymetrics.io/docs/usage/quick-start/

    For the port part, I have never used noip so I can not help you with that part, on any dedicated/vps server you would open port 3000 on TCP and access the application via IP:3000 or on localmachine via localhost:3000 or 127.0.0.1:3000


  • @NeHo said in WebAdmin Install: A lot further than before but not quite there!:

    pm2 delete 1

    Hi,

    pm2 side of life is sorted.

    Regarding noip, that does not matter. That for me it is a back up just in case my IP changes and no one can then find the servers. I don't have static IP at home because it costs too much money. The servers are found using the domain name, which the IP resolves through. IP has never changed anyway for at least two years. I have a linux machine at home with game servers on, website on and I access it through my windows machine. When i look at my website I use the local IP address (no problem) anything i access on the machine i do locally. I do not see the 'outside world'

    I have an IP address so I don't know what you mean regarding NOIP. That's really nothing to do with it I would say. If it changed (it wont) tomorrow we should still be able to set up today? Port 3000 is open on my public IP address. 85.134.2.83 Making no sense to me. But as i said many times, its above my 'payscale'

    I really have followed everything that's been given to me support wise. Time to go back to old fashioned echelon and b3 ? 🙂


  • NodeJS defaults to IPv6 when listening for connections is what I have come up with. Needs to be on IPv4 but how to change that and try (if that is the problem at all) I have no idea. The ideas other than forget it are dry..haha


  • No further answers anywhere.

    So to get rid of all this simply delete the folder ?

    Need to remove any installed packages ? Mongodb etc etc?

    I’ve tried with 16.04, 18.04, My local server and a rented one all with errors.


  • @FMJ-Smiley hello bro how did you fix it? I get the same error.

  • Administrators

    I helped you to manage and start my application, the application runs, mongoDB runs everything works, you have to figure out how you can access your own machine, I can't help you with that part.

    The problem is not with the application, your problem is that you don't know how to access your local machine, you are using noip solutions, workarounds and I can't help you in router settings, port forwards etc ...


  • Like i said before thank you for the help. It really is appreciated.

    I don't see how it can be noip. That is a back up in case IP address changes. Today and everyday for the last 2 years my IP address is the same. My local addresses are the same. I can access everything on my machine locally but not your application. Look at all the problems people have with node.js defaulting to ipv6. I don't see or find a solution to that and I know nothing about it.

    @ravindu2500 My problem is not solved. Sorry I cannot help.


  • @FMJ-Smiley okay bro it's solved 🙂 Thanks ❤


  • I have also solved the issue and can now see the application. Nothing to do with NOIP.

    sudo iptables -I INPUT -p tcp --dport 3000 -j ACCEPT did the trick.

  • Administrators

    @FMJ-Smiley said in WebAdmin Install: A lot further than before but not quite there!:

    I have also solved the issue and can now see the application. Nothing to do with NOIP.

    sudo iptables -I INPUT -p tcp --dport 3000 -j ACCEPT did the trick.

    Well sudo iptables has nothing to do with my application, glad you solved it


  • Thank you.

    No idea but I was reading why node applications would not open up on localhost:3000 and it led me to that. It worked 🙂


  • I'm having the same problem as ravindu with v2 recaptcha. Waited over the 30 mins that Google say for them to 'save' Also made new keys and still no good. I can login with default admin from seed 'first install'

    My admin page looks like this! 2020-04-30 04_03_19-undefined - =FMJ=FullMetalJacket.png

802
172
117
Visitors Today
Powered & Designed by NeHo